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Using Excel to Solve Complex Problems 
Microsoft Excel can be used to solve complex problems. For example, suppose a 
manufacturing firm has four main jobs and twenty employees who need to be 
assigned to those jobs. As shown in table 1 below, their managers have evaluated 
each employee’s competency score, on a scale of one-to-ten, for the four jobs. The 
employer of course wants to maximize the firm’s productivity.  

The employer also wants to maximize employees’ job satisfaction, provided it does 
not ruin productivity. Table 2 is from an employee survey that shows each employee’s 
satisfaction with the four jobs. Your job is to help them by setting up an Excel 
spreadsheet that can maximize both productivity (competence) and employee 
satisfaction. 

Table 1: Competency Scores 

Worker  Job 1  Job 2  Job 3  Job 4  
1 9 8 6 8 
2 10 0 5 6 
3 5 8 10 5 
4 4 0 5 2 
5 9 10 4 5 
6 5 2 7 3 
7 8 3 1 2 
8 2 2 9 2 
9 8 7 6 3 

10 7 0 1 8 
11 8 1 6 6 
12 0 7 1 2 
13 9 0 5 4 
14 9 2 2 7 
15 1 3 8 4 
16 9 6 4 5 
17 8 0 5 0 
18 6 7 6 3 
19 3 4 5 4 
20 3 9 4 4 

 

Table 2: Satisfaction Scores 

Worker  Job 1  Job 2  Job 3  Job 4  
1 1 2 6 7 
2 9 6 7 4 
3 1 7 7 3 
4 9 1 0 3 
5 9 8 8 3 
6 2 8 1 5 
7 1 8 2 2 
8 8 3 1 6 
9 4 3 4 1 

10 4 1 5 4 
11 2 0 9 3 
12 5 2 1 1 
13 3 0 7 8 
14 1 1 2 10 
15 9 8 6 8 
16 5 7 8 8 
17 5 7 2 4 
18 2 4 1 6 
19 8 7 6 6 
20 2 2 2 3 
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Step-by-Step Exercises 

Exercise 1: Enhance the labels 
In this exercise you will open an Excel file that has the worker numbers and their job 
scores. You will then enhance the labels using some custom number formats, bolding, 
borders, and by merging cells. 

1) Download the Solver_Start.xlsx file. 

2) Bold the data in A2:I2. 

3) Format the job numbers with the word “job”. 

a) Select B2:I4. 

b) Press Ctrl + 1  to display the Format Cells dialog box. 

c) On the Number tab, in the Type well, enter the following code: 

"Job "#,##0_)  

Note: the use of the following characters: 

• The text in quotes is literal text that will appear before the number. 

• The pound signs represent optional digits that appear if needed. 

• The comma represents the thousands separator. 

• The zero represents a required digit. 

• The underscore and parenthesis are optional. They add extra space that is 
the width of a single closed parenthesis. They are often used to align a 
positive number with negative numbers that are displayed with parenthesis. 

4) Bold the labels in B1 and F1. 

5) Add borders: 

a) Select A1:I22. 

b) From the ribbon, choose Home > Font > Borders > All Borders. 

6) Select cells B1:E1 then merge them together via Home > Alignment > Merge & 
Center > Merge Cells. 

7) Select cells F1:I1 then merge them together via Home > Alignment > Merge & 
Center > Merge Cells. 

8) Select cells A1:A2 then merge them together via Home > Alignment > Merge & 
Center > Merge Cells. 

https://techmentor-public.b-cdn.net/free_stuff/Excel_Solver/Solver_Start.xlsx
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Exercise 2: Add columns for scores and the assigned group. 
In this exercise you will add new columns and labels that will be used to assign workers 
to different jobs and for showing the related results scores.  

1) Insert a new column F. 

2) Enter C Score  in cell F2. 

3) Enter S Score  in cell K2. 

4) If needed, bold both F2 and K2. 

5) Add borders to F2 and K2. 

a) Select F2 and K2. 

b) Press Ctrl + 1  to display the Format Cells dialog box. 

c) Select the Border tab. 

d) Click on the left border to remove it. 

e) Click OK. 

6) Use the Calculation style to identify the location of the score calculations. 

a) Select cells F3:F22. 

b) From the ribbon, choose Home > Styles > Calculation. 

c) Select cells K3:K22. 

d) From the ribbon, choose Home > Styles > Calculation. 

7) Enter Assigned Group  in cell L1. 

8) Bold the text in L1. 

9) Wrap the text in cell L1. 
From the ribbon, choose Home > Alignment > Wrap Text.  

10) Merge cells L1 and L2 by selecting L1:L2, then merge them together via Home > 
Alignment > Merge & Center > Merge Cells. 

11) If needed, bottom align the text in cell L1. 

12) If needed, add all borders to L1. 
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13) Use the input style to identify the location of the input cells. 

a) Select cells L3:L22. 

b) From the ribbon, choose Home > Styles > Input. 

14) Save your work. 

Exercise 3: Add score calculations 
In this exercise you will enter the score calculations. 

1) Temporarily assign jobs to the first four workers by entering the following values: 

L3 1  

L4 2  

L5 1  

L6 4  

2) To simply formula creation, create two named ranges to represent the Job 
Competence Scores and the Satisfaction Scores. 

a) Select cells B2:E22. 

b) In the name box, enter CJobs . 

c) Select cells G2:K22. 

d) In the name box, enter SJobs . 

3) In cell F3 enter the following formula: 

=IFERROR(HLOOKUP($L3,CJobs,$A3+1),"")  

The formula uses the HLookup function to look up the job score value of cell L3 in 
the CJobs list and then returns the value that corresponds to the worker # (A3). 
The +1 is included because the worker number is one row below the top of the 
CJobs list. 

The formula also uses the IfError function to fix errors that would occur with the 
HLookup function when the Assigned Group is blank. 

4) Autofill the formula in F3, by double clicking its bottom right corner. 

5) In cell K3, enter the following formula: 
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=IFERROR(HLOOKUP($L3,SJobs,$A3+1),"")  

This formula also uses the HLookup and IfError functions in a similar fashion to get 
the satisfaction scores for the worker’s assigned group. 

6) Autofill the formula in K3, by double clicking its bottom right corner. 

7) Save your work. 

Exercise 4: Summarize all the scores 
I this exercise you will summarize all the scores and count the number of employees 
assigned to each job. 

1) In cell F1, enter the following formula to add up all the C Scores. 

=SUM(F2:F22)  

2) Use format painter to copy the cell format of F3 to F1. 

3) In cell K1, enter the following formula to add up all the C Scores. 

=SUM(K2:K22)  

4) Use format painter to copy the cell format of K3 to K1. 

5) If desired, use the following custom number format to add three spaces after the 
calculated score in cells F1:F22 and K1:K22. 

#,##0   ;  

6) Save your work. 

Exercise 5: Count the number of assigned jobs 
In this exercise you will count the number of employees assigned to each job. 

1) Enter the following values in cells O2:P6. 

Cell Value 

O2 Job  

O3 1  

O4 2  
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O5 3  

O6 4  

P2 Assigned  

2) Bold the values in O2:P6. 

3) Add borders to cells O2:P6. 

4) In cells P3:P6 apply the Calculation style. 

5) Create a named range the Assigned Job List. 

a) Select cells L3:L22. 

b) In the name box, enter AssignedJobList . 

6) In cell P3 enter the following formula: 

=COUNTIF(AssignedJobList,$O3)  

This formula uses the CountIf function to count the number of employees that were 
assigned to each job. 

8) Autofill the formula in P3, by double clicking its bottom right corner. 

7) Optional: Experiment assigning different employees to different jobs in the 
AssignedJobList. 

Exercise 6: Display Penalties 
The company wants to ensure that at least three employees are assigned to each job, 
and that no job has more than seven employees. Therefore, in this exercise you will 
add a penalty to each job that violates these rules. You will also add a penalty 
message that will identify the reason for the penalty. 

1) Enter Penalty  in cell Q2. 

2) Bold cell Q2. 

3) Enter the following formula in cell Q3. 

=IF(OR(P3<3,P3>7),1,0)  
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This formula uses the OR and IF functions. If P3 is under three OR over seven then 
a one is assigned. If not, a zero is assigned. 

4) Autofill the formula in Q3, by double clicking its bottom right corner. 

5) Enter Total Penalty  in cell P7. 

6) Bold and right justify cell P7. 

7) Sum the penalties by entering the following formula in cell Q7. 

=SUM(Q3:Q6)  

8) Apply the Calculation style to cells Q3:Q7. 

9) Enter the following formula to alert the user with an appropriate message if a 
penalty has been assigned.  

=SWITCH(TRUE,P3<3,"Assigned is less than 3", P3>7,"Assigned is  

greater than 7","")  

 

Optional: Instead of entering a long one-line formula, you may use Alt + Enter  

at the end of each line to create a multi-line formula as shown below. 

=SWITCH(TRUE,  

P3<3,"Assigned is less than 3",  

P3>7,"Assigned is greater than 7",  

"")  

This formula uses the Switch function. The switch function is used to evaluate 
multiple conditions.  When the first argument is TRUE the Switch function acts like 
multiple IF statements.  

• In our case the first pair determines if P3 is less than 3, and if so, returns the 
message “Assigned is less that 3”.  

• In our formula the second pair determines if P3 is greater than 7. If so, the 
“Assigned is greater than 7” message is returned. 

• If none of the conditions are met, then the final argument, “”, is returned. 

10) Autofill the formula in R3, by double clicking its bottom right corner. 

11) Apply the Calculation style to cells R3:R6. 
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12) Merge cells Q2:T2 into one cell. 

13) Merge cells R3:T6 into four cells by doing the following: 

a) Select cells R3:T6. 

b) From the ribbon choose Home > Alignment > Merge & Center > 
Merge Across. 

14) Add all borders to cells O2:T6. 

15) Test the penalties by adding a 1  in cell L7. 

16) Save your work. 

Understanding the Solve Add-In 
Microsoft’s free Excel Solver Add-In can help users find the best possible solution to a 
complex problem. It does so by changing one or more input cells, subject to business 
constraints that you identify. The solver is often used as a what-if tool to analyze, 
optimize, and help you solve business, science, engineering and/or economics 
problems. 

What Solver Does 

Solver works by: 

• Changing decision variables (input cells you choose), 

• To optimize an objective cell (maximize, minimize, or set to a specific value), 

• Subject to constraints (limits or rules the solution must obey). 
 
For example, Solver can be used to: 

• Maximize profit given production constraints 

• Minimize costs while meeting demand 

• Allocate budgets or resources optimally 

• Schedule work subject to time or capacity limits 

Key Components Users Should Know 

When using Solver, students must identify: 
1. An Objective Cell – the result to optimize (e.g., total profit) 
2. Variable Cells – the inputs Solver is allowed to change 
3. Constraints – rules such as limits, minimums, maximums, or integers 

Exercise 7: Use the Solver to assign employees to their jobs 
In this final exercise you will use the Solver Add-in to let Excel assign the employees to 
the various jobs with the goal of both maximizing competence and employee 
satisfaction. 
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1) Verify that the Solver add-in is installed: 

a) From the ribbon select File > Options > Add-ins. 

b) Next to the Mange drop down click the Go… button. 

c) If necessary, check the Solver Add-In option. 

d) Click OK. 

e) From the ribbon, click on the Data tab. 

f) Verify you have an Analyze group that now includes the Solver button. 

2) Enter the following values with the desired formatting in columns P:T. 

Cell Value Formats  Cell Value Formats 

P10 Total Competence  Right justified  R9 Multiplier  Bold 

P11 Total Satisfaction  Right justified  S9 Score  Bold 

P12 '- Total Penalty  Right justified     

P13 Total Score  
Right justified  
Bold 

    

3) Enter the following formulas / values with the desired formatting in columns O:S. 
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Cell Formula Formats  Cell Value Formats 

Q10 =F1  Calculation Style  R10 3  Input Style 

Q11 =L1  Calculation Style  R11 1  Input Style 

Q12 =-Q7  Calculation Style  R12 1000  Input Style 

S10 =Q10*R10  
Calculation Style 
General Number format 

 
   

S11 =Q11*R11  
Calculation Style 
General Number format 

 
   

S12 =Q12*R12  
Calculation Style 
General Number format 

 
   

S13 =SUM(S10:S12)  
Calculation Style 
General Number format 

 
   

You will now use the solver to maximize the total score (cell S13) provided that the 
employee assignments are for a job number between 1 and 4.  

4) Select cell S13. 

5) From the ribbon select Data > Analyze > Solver. 

6) For the Set Objective choose cell S13. 

7) For the To: option choose Max. 

8) For the By Changing Variable Cells: option choose AssignJobList . 

9) For the Subject to the Constraints: 
a) Click the Add button. 

b) For the Cell Reference: choose AssignJobList . 

c) Set the operator drop-down to <= . 

d) For the Constraint enter 4 . 

e) Click the Add button. 

f) For the Cell Reference: choose AssignJobList . 

g) Set the operator drop-down to >= . 

h) For the Constraint enter 1 . 
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i) Click the Add button. 

j) For the Cell Reference: choose AssignJobList . 

k) Set the operator drop-down to int . 

l) Click OK. 

m) For the Select a Solving Method: choose Evolutionary . 

n) Click the Solve button. 
o) Allow the solver to run for about 60 to 90 seconds. 

p) When the Solver Results dialog box is displayed, choose Keep Solver Solution 
and then click OK. 
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